Back to overview
Resolved

Progress Data Cloud maintenance & Service Interruption

Jul 14, 2026 at 7:00am UTC  –  Jul 14, 2026 at 10:00am UTC
Affected services
Progress Data Cloud (East US, CA, Gov)

Resolved
Jul 14, 2026 at 10:00am UTC

Maintenance ended

Created
Jul 14, 2026 at 7:00am UTC

On Tuesday, July 14, between 7:00 AM and 10:00 AM UTC, we will be performing scheduled maintenance to Progress Data Cloud infrastructure in the following regions: East US, Canada, and US Gov. During this window, customers in these regions may experience a brief service interruption.